AU or VST?


#1

What is the difference between AU and VSTa and what should I be running?
Thx!


#2

In principle there should be no difference but my personal experience is that VSTs are generally less buggy, probably because they’re tested against many more hosts than are AUs.


#3

Just to add that if there are any plans to open your gig files on Windows at some point - it would be better if you used VSTs since in that case we can try to find a replacement on the new system. (note: this functionality will be available soon)


#4

I’m on the Mac platform.
Mark


#5

On my early 2011 MBP, the GUI of the VST version of Softube Saturation Knob does not display in GP…followed by a Crash popup. The AU version works fine, however.
Wonder if this issue might be caused by my OS – Mavericks – although, the VST version runs fine in Ableton Live 9x.
Thoughts?
Mike


#6

Mike, just disable open gl in the setup of softube plugins.
You should use a different host to do that ?


#7

Hmmm, I’ve just sent an email to Softube about this — I don’t love the idea of users having to use a different host just to disable Open GL. Maybe everyone having this problem should reach out to Softube directly and ask for a way to disable Open GL without having to first open the plugin in question.


#8

Thanks, Pianopaul and David! I’ll disable Open GL (in another host) and report back here. I’ll also drop a Support note to Softube.

Best regards,

Mike


#9

Here’s the reply I got from Softube regarding Open GL


It should be possible to disable Open GL without opening the plug-ins first. I believe this is how you do it…

…on Windows:

  1. Make sure the DAW is not running.
  2. Go to the folder C:\Users<$USERNAME>\AppData\Roaming\Softube

3.a. If the file “Softube Global Settings.txt” is there, open it and edit the line “USE_OPENGL BOOLEAN”, change “1” to “0”. Save.
3.b. If it isn’t: Copy the attached file to the folder specified above.

  1. Launch the DAW.

…and on Mac:

  1. Make sure the DAW is not running.
  2. In the Finder, click the “Go” menu in the menu bar.
  3. From the “Go” menu, navigate down to “Go to Folder”.
  4. Go to the folder ~/Library/Application Support/Softube/

5.a If the file “Softube Global Settings.txt” is there, open it and edit the line “USE_OPENGL BOOLEAN”, change “1” to “0”. Save.
b If it isn’t: Copy the attached file to the folder specified above.

  1. Launch the DAW.

#10

Hmmm…can’t seem to locate the file attachment for Mac [nor the one for Win, for that matter]. Any chance that the file can be emailed to me?
mikedee12959 at optonline dot net
Thanks and regards,
Mike


#11

I don’t have an attachment — that’s what they sent me. I ASSUME that the attachment is probably just a file called “Softube Global Settings.txt” stored in the appropriate folder. If you don’t already have that file, then create it!


#12

LØL, David…that’s exactly what I was attempting to do. But then I figured: no harm in taking the lazy man’s route here…simply fired up another DAW and unchecked the Use OpenGL box…all féèx. :wink:

Best regards,

Mike


#13

IMPORTANT UPDATE:

I did, in fact, find the Softube Global Settings.txt file…under the HIDDEN Library folder [MAC]. After clicking the Go menu, I held down the Option key to expose the hidden Library menu item…then I could navigate to …/Application Support/Softube (where I located the file).
Since I had already unchecked the Use OpenGL box yesterday, the file was modified accordingly (the resulting timestamp confirmed so).

For anyone who still cannot find the file, here are the contents of mine (4 lines):

FILE_VERSION 2
SHOW_DELETE_PRESET_COLLECTION_DIALOG BOOLEAN 1
SHOW_OVERWRITE_PRESET_COLLECTION_DIALOG BOOLEAN 1
USE_OPENGL BOOLEAN 0
 

[Obviously, the last line’s bool value was 1 until I unchecked the box yesterday.]

Hope this helps,
Mike


#14

Duplicate…thought original was lost, lol.